Debian DSA-535-1 : squirrelmail - several vulnerabilities

critical Nessus Plugin ID 15372

Synopsis

The remote Debian host is missing a security-related update.

Description

Four vulnerabilities were discovered in squirrelmail :

- CAN-2004-0519 Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

- CAN-2004-0520

Cross-site scripting (XSS) vulnerability in mime.php for SquirrelMail before 1.4.3 allows remote attackers to insert arbitrary HTML and script via the content-type mail header, as demonstrated using read_body.php.

- CAN-2004-0521

SQL injection vulnerability in SquirrelMail before 1.4.3 RC1 allows remote attackers to execute unauthorized SQL statements, with unknown impact, probably via abook_database.php.

- CAN-2004-0639

Multiple cross-site scripting (XSS) vulnerabilities in Squirrelmail 1.2.10 and earlier allow remote attackers to inject arbitrary HTML or script via (1) the $mailer variable in read_body.php, (2) the $senderNames_part variable in mailbox_display.php, and possibly other vectors including (3) the $event_title variable or (4) the $event_text variable.

Solution

For the current stable distribution (woody), these problems have been fixed in version 1:1.2.6-1.4.

We recommend that you update your squirrelmail package.

See Also

http://www.debian.org/security/2004/dsa-535

Plugin Details

Severity: Critical

ID: 15372

File Name: debian_DSA-535.nasl

Version: 1.24

Type: local

Agent: unix

Published: 9/29/2004

Updated: 1/4/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:squirrelmail, cpe:/o:debian:debian_linux:3.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/2/2004

Vulnerability Publication Date: 4/27/2004

Reference Information

CVE: CVE-2004-0519, CVE-2004-0520, CVE-2004-0521, CVE-2004-0639

BID: 10246, 10439

DSA: 535