VMware vCenter Server < 6.7 Multiple Vulnerabilities (VMSA-2021-0020)

critical Nessus Plugin ID 153544

Synopsis

A virtualization management application installed on the remote host is affected by multiple vulnerabilities.

Description

The version of VMware vCenter Server installed on the remote host is 6.7 prior to 6.7 U3o. It is, therefore, affected by multiple vulnerabilities:

- A privilege escalation vulnerability exists in vCenter Server due to the way it handles session tokens. An authenticated, local attacker can exploit this to gain unauthorized access to the system. (CVE-2021-21991, CVE-2021-22015)

- A reverse proxy bypass vulnerability exists in vCenter Server due to the way the endpoints handle the URI. An unauthenticated, remote attacker can exploit this to gain unauthorized access to restricted endpoints.
(CVE-2021-22006)

- An rhttproxy bypass vulnerability exists in vCenter Server due to improper implementation of URI normalization. An unauthenticated, remote attacker can exploit this to gain access to internal endpoints. (CVE-2021-22017)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number. Nessus has also not tested for the presence of a workaround.

Solution

Upgrade to VMware vCenter Server 6.7 U3o or later or apply the workaround mentioned in the advisory.

See Also

https://www.vmware.com/security/advisories/VMSA-2021-0020.html

Plugin Details

Severity: Critical

ID: 153544

File Name: vmware_vcenter_67_u3o_vmsa-2021-0020.nasl

Version: 1.11

Type: remote

Family: Misc.

Published: 9/22/2021

Updated: 5/9/2022

Risk Information

CVSS Score Source: CVE-2021-22014

VPR

Risk Factor: Critical

Score: 9.5

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/21/2021

Vulnerability Publication Date: 9/21/2021

CISA Known Exploited Dates: 11/17/2021, 1/24/2022

Exploitable With

Metasploit (VMware vCenter Server Analytics (CEIP) Service File Upload)

Reference Information

CVE: CVE-2021-21991, CVE-2021-21992, CVE-2021-21993, CVE-2021-22005, CVE-2021-22006, CVE-2021-22007, CVE-2021-22008, CVE-2021-22009, CVE-2021-22010, CVE-2021-22011, CVE-2021-22014, CVE-2021-22015, CVE-2021-22016, CVE-2021-22017, CVE-2021-22019, CVE-2021-22020

IAVA: 2021-A-0434