Microsoft Open Management Infrastructure (OMI) package < 1.6.8-1 Multiple Vulnerabilities

critical Nessus Plugin ID 153475

Synopsis

A package installed on the remote host is affected by multiple vulnerabilities.

Description

The version of Microsoft Open Management Infrastructure (OMI) package installed on the remote host is prior to 1.6.8-1. It is, therefore, affected by multiple vulnerabilities:

- A remote code execution vulnerability exists in the OMI agent. An unauthenticated, remote attacker can exploit this to bypass authentication and execute arbitrary commands with root privileges. (CVE-2021-38647)
- Multiple privilege escalation vulnerabilities exists in the OMI agent. An unauthenticated, remote attacker can exploit this, to gain privileged access to the system. (CVE-2021-38645, CVE-2021-38648, CVE-2021-38649)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to version 1.6.8-1 or later.

See Also

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-38647

https://www.wiz.io/blog/omigod-critical-vulnerabilities-in-omi-azure

https://github.com/microsoft/omi/releases

Plugin Details

Severity: Critical

ID: 153475

File Name: omi_1_6_8_1.nasl

Version: 1.7

Type: local

Agent: unix

Family: Misc.

Published: 9/17/2021

Updated: 11/30/2021

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-38647

VPR

Risk Factor: Critical

Score: 9.6

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/a:microsoft:open_management_infrastructure

Required KB Items: Host/local_checks_enabled

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/8/2021

Vulnerability Publication Date: 9/14/2021

CISA Known Exploited Dates: 11/17/2021

Exploitable With

Metasploit (Microsoft OMI Management Interface Authentication Bypass)

Reference Information

CVE: CVE-2021-38645, CVE-2021-38647, CVE-2021-38648, CVE-2021-38649

IAVA: 2021-A-0433