Adobe Digital Editions <= 4.5.11.187646 Multiple Vulnerabilities (macOS) (APSB21-80)

high Nessus Plugin ID 153436

Synopsis

An application installed on the remote macOS host is affected by multiple vulnerabilities.

Description

Adobe Digital Editions version 4.5.11.187646 (and earlier) is affected by multiple vulnerabilities, as follows:

- An OS command injection vulnerability that can be exploited by a local attacker to execute arbitrary code. (CVE-2021-39826)

- An arbitrary file system write vulnerability that can be exploited by a local attacker. (CVE-2021-39827)

- A privilege escalation vulnerability that can be exploited by a local attacker. (CVE-2021-39828)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Digital Editions version 4.5.11.187658 or later.

See Also

http://www.nessus.org/u?e229dead

Plugin Details

Severity: High

ID: 153436

File Name: macosx_adobe_digital_editions_apsb21-80.nasl

Version: 1.4

Type: local

Agent: macosx

Published: 9/16/2021

Updated: 10/4/2021

Configuration: Enable paranoid mode

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.5

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39826

CVSS v3

Risk Factor: High

Base Score: 8.6

Temporal Score: 7.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:digital_editions

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Digital Editions, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/14/2021

Vulnerability Publication Date: 9/14/2021

Reference Information

CVE: CVE-2021-39826, CVE-2021-39827, CVE-2021-39828

IAVA: 2021-A-0423