Palo Alto Networks PAN-OS 9.0.10 < 9.0.15 / 9.1.4 < 9.1.11 / 10.0.x < 10.0.8 / 10.1.x < 10.1.2 OS Command Injection

high Nessus Plugin ID 153213
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote PAN-OS host is affected by an os command injection vulnerability.

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 9.0.10 prior to 9.0.15, 9.1.4 prior to 9.1.11, 10.0.x prior to 10.0.8 or 10.1.x prior to 10.1.2. It is, therefore, affected by a command injection vulnerability in its web interface component due to insufficient validation of user supplied input. An authenticated, remote attacker can exploit this, by sending specially crafted requests, to execute arbitrary commands on an affected host.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 9.0.15 / 9.1.11 / 10.0.8 / 10.1.2 or later

See Also

https://security.paloaltonetworks.com/CVE-2021-3050

Plugin Details

Severity: High

ID: 153213

File Name: palo_alto_CVE-2021-3050.nasl

Version: 1.2

Type: combined

Published: 9/10/2021

Updated: 9/13/2021

Dependencies: palo_alto_version.nbin

Risk Information

CVSS Score Source: CVE-2021-3050

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 8/11/2021

Vulnerability Publication Date: 8/11/2021

Reference Information

CVE: CVE-2021-3050