Ubuntu 18.04 LTS / 20.04 LTS / 21.04 : SSSD vulnerabilities (USN-5067-1)

medium Nessus Plugin ID 153144
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 21.04 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5067-1 advisory.

- A flaw was found in sssd Group Policy Objects implementation. When the GPO is not readable by SSSD due to a too strict permission settings on the server side, SSSD will allow all authenticated users to login instead of denying access. (CVE-2018-16838)

- The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.
(CVE-2018-10852)

- A vulnerability was found in sssd. If a user was configured with no home directory set, sssd would return '/' (the root directory) instead of '' (the empty string / no home directory). This could impact services that restrict the user's filesystem access to within their home directory through chroot() etc. All versions before 2.1 are vulnerable. (CVE-2019-3811)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5067-1

Plugin Details

Severity: Medium

ID: 153144

File Name: ubuntu_USN-5067-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 9/8/2021

Updated: 9/24/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2018-16838

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:21.04, p-cpe:/a:canonical:ubuntu_linux:libipa-hbac-dev, p-cpe:/a:canonical:ubuntu_linux:libipa-hbac0, p-cpe:/a:canonical:ubuntu_linux:libnss-sss, p-cpe:/a:canonical:ubuntu_linux:libpam-sss, p-cpe:/a:canonical:ubuntu_linux:libsss-certmap-dev, p-cpe:/a:canonical:ubuntu_linux:libsss-certmap0, p-cpe:/a:canonical:ubuntu_linux:libsss-idmap-dev, p-cpe:/a:canonical:ubuntu_linux:libsss-idmap0, p-cpe:/a:canonical:ubuntu_linux:libsss-nss-idmap-dev, p-cpe:/a:canonical:ubuntu_linux:libsss-nss-idmap0, p-cpe:/a:canonical:ubuntu_linux:libsss-simpleifp-dev, p-cpe:/a:canonical:ubuntu_linux:libsss-simpleifp0, p-cpe:/a:canonical:ubuntu_linux:libsss-sudo, p-cpe:/a:canonical:ubuntu_linux:libwbclient-sssd, p-cpe:/a:canonical:ubuntu_linux:libwbclient-sssd-dev, p-cpe:/a:canonical:ubuntu_linux:python-libipa-hbac, p-cpe:/a:canonical:ubuntu_linux:python-libsss-nss-idmap, p-cpe:/a:canonical:ubuntu_linux:python-sss, p-cpe:/a:canonical:ubuntu_linux:python3-libipa-hbac, p-cpe:/a:canonical:ubuntu_linux:python3-libsss-nss-idmap, p-cpe:/a:canonical:ubuntu_linux:python3-sss, p-cpe:/a:canonical:ubuntu_linux:sssd, p-cpe:/a:canonical:ubuntu_linux:sssd-ad, p-cpe:/a:canonical:ubuntu_linux:sssd-ad-common, p-cpe:/a:canonical:ubuntu_linux:sssd-common, p-cpe:/a:canonical:ubuntu_linux:sssd-dbus, p-cpe:/a:canonical:ubuntu_linux:sssd-ipa, p-cpe:/a:canonical:ubuntu_linux:sssd-kcm, p-cpe:/a:canonical:ubuntu_linux:sssd-krb5, p-cpe:/a:canonical:ubuntu_linux:sssd-krb5-common, p-cpe:/a:canonical:ubuntu_linux:sssd-ldap, p-cpe:/a:canonical:ubuntu_linux:sssd-proxy, p-cpe:/a:canonical:ubuntu_linux:sssd-tools

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 9/8/2021

Vulnerability Publication Date: 6/26/2018

Reference Information

CVE: CVE-2018-10852, CVE-2018-16838, CVE-2019-3811, CVE-2021-3621

USN: 5067-1