ImageMagick 7.0.0 < 7.0.9-0 Denial of Service

low Nessus Plugin ID 152959
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has an application installed that is affected by a denial of service vulnerability.

Description

The remote Windows host has a version of ImageMagick installed that is prior to 7.0.x prior to 7.0.9-0. It is, therefore, affected by a denial of service (DoS) vulnerability in magick/quantum-private.h due to improper checking of values assgined to type of 'unsigned int'. An unauthenticated, local attacker can exploit this issue, to cause the application to stop responding.

Solution

Upgrade to ImageMagick version 7.0.9-0 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

https://github.com/ImageMagick/ImageMagick/issues/1751

http://www.nessus.org/u?31f91467

Plugin Details

Severity: Low

ID: 152959

File Name: imagemagick_7_0_9.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 9/1/2021

Updated: 9/3/2021

Dependencies: imagemagick_installed.nasl

Risk Information

CVSS Score Source: CVE-2020-27768

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Ease: No known exploits are available

Patch Publication Date: 10/13/2019

Vulnerability Publication Date: 10/13/2019

Reference Information

CVE: CVE-2020-27768

IAVB: 2020-B-0076-S