Ubuntu 16.04 LTS : QPDF vulnerabilities (USN-5026-2)

medium Nessus Plugin ID 152178
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5026-2 advisory.

- In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file. (CVE-2018-18020)

- QPDF 9.x through 9.1.1 and 10.x through 10.0.4 has a heap-based buffer overflow in Pl_ASCII85Decoder::write (called from Pl_AES_PDF::flush and Pl_AES_PDF::finish) when a certain downstream write fails. (CVE-2021-36978)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected libqpdf-dev, libqpdf21 and / or qpdf packages.

See Also

https://ubuntu.com/security/notices/USN-5026-2

Plugin Details

Severity: Medium

ID: 152178

File Name: ubuntu_USN-5026-2.nasl

Version: 1.2

Type: local

Agent: unix

Published: 8/2/2021

Updated: 8/2/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-36978

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libqpdf-dev, p-cpe:/a:canonical:ubuntu_linux:libqpdf21, p-cpe:/a:canonical:ubuntu_linux:qpdf

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 8/2/2021

Vulnerability Publication Date: 10/6/2018

Reference Information

CVE: CVE-2018-18020, CVE-2021-36978

USN: 5026-2