RabbitMQ < 3.8.18 XSS

medium Nessus Plugin ID 152141
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A web application running on the remote web server is affected by denial of service vulnerability.


Pivotal RabbitMQ versions prior to 3.8.18 are affected by a cross-site scripting (XSS) vulnerability in the rabbitmq_federation_management plugin due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Pivotal RabbitMQ version 3.8.18 or later.

See Also



Plugin Details

Severity: Medium

ID: 152141

File Name: rabbitmq_3_8_18.nasl

Version: 1.3

Type: local

Agent: unix

Family: Misc.

Published: 7/29/2021

Updated: 8/2/2021

Dependencies: rabbitmq_server_nix_installed.nbin

Risk Information

CVSS Score Source: CVE-2021-32719


Risk Factor: Low

Score: 3


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pivotal_software:rabbitmq

Required KB Items: installed_sw/RabbitMQ

Exploit Ease: No known exploits are available

Patch Publication Date: 6/25/2021

Vulnerability Publication Date: 6/27/2021

Reference Information

CVE: CVE-2021-32719

IAVB: 2021-B-0043