CODESYS V2 Web Server Improperly Implemented Security Check (2021-07)

critical Nessus Plugin ID 152098
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The CODESYS V2 web server has an improperly implemented security check.

Description

The remote CODESYS V2 web server has an improperly implemented security check. Crafted web server requests can bypass the security checks for boot project-related files on the CODESYS Control runtime system to upload them from the CODESYS Control runtime system.

Solution

Upgrade CODESYS V2 web server to 1.1.9.20 or higher.

See Also

http://www.nessus.org/u?d28644c1

https://us-cert.cisa.gov/ics/advisories/icsa-21-173-02

Plugin Details

Severity: Critical

ID: 152098

File Name: scada_codesys_2021-07.nbin

Version: 1.6

Type: remote

Family: SCADA

Published: 7/27/2021

Updated: 11/29/2021

Dependencies: scada_codesys_v2_web_server_detect.nbin

Risk Information

CVSS Score Source: CVE-2021-30192

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/a:codesys:v2_web_server

Required KB Items: installed_sw/CODESYS V2 Web Server

Exploit Ease: No known exploits are available

Patch Publication Date: 5/11/2021

Vulnerability Publication Date: 6/29/2021

Reference Information

CVE: CVE-2021-30192

ICSA: 21-173-02