Node.js 12.x < 12.22.2 / 14.x < 14.17.2 / 16.x < 16.4.1 Multiple Vulnerabilities

medium Nessus Plugin ID 151975
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.

Description

The version of Node.js installed on the remote host is prior to 12.22.2, 14.17.2, 16.4.1. It is, therefore, affected by multiple vulnerabilities as referenced in the July 2021 Security Releases advisory.

- Node.js is vulnerable to out-of-bounds read in libuv's uv__idna_toascii() function which is used to convert strings to ASCII. This is called by Node's dns module's lookup() function and can lead to information disclosures or crashes. (CVE-2021-22918)

- Node.js is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms.
More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking. (CVE-2021-22921)

- This is a vulnerability in the ssri npm module which may be vulnerable to denial of service attacks.
(CVE-2021-27290)

- This is a vulnerability in the hosted-git-info npm module which may be vulnerable to denial of service attacks. (CVE-2021-23362)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Node.js version 12.22.2 / 14.17.2 / 16.4.1 or later.

See Also

https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/

Plugin Details

Severity: Medium

ID: 151975

File Name: nodejs_2021_jul.nasl

Version: 1.4

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 7/22/2021

Updated: 9/3/2021

Dependencies: macosx_nodejs_installed.nbin, nodejs_win_installed.nbin

Risk Information

CVSS Score Source: CVE-2021-22918

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: installed_sw/Node.js

Exploit Ease: No known exploits are available

Patch Publication Date: 7/1/2021

Vulnerability Publication Date: 3/12/2021

Reference Information

CVE: CVE-2021-22918, CVE-2021-22921, CVE-2021-23362, CVE-2021-27290

IAVB: 2021-B-0041-S