Drupal 7.x < 7.82 / 8.9.x < 8.9.17 / 9.1.x < 9.1.11 / 9.2.x < 9.2.2 Drupal Vulnerability (SA-CORE-2021-004)

high Nessus Plugin ID 151932
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A PHP application running on the remote web server is affected by a vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.82, 8.9.x prior to 8.9.17, 9.1.x prior to 9.1.11, or 9.2.x prior to 9.2.2. It is, therefore, affected by a vulnerability.

- The Drupal project uses the pear Archive_Tar library, which has released a security update that impacts Drupal. The vulnerability is mitigated by the fact that Drupal core's use of the Archive_Tar library is not vulnerable, as it does not permit symlinks. Exploitation may be possible if contrib or custom code uses the library to extract tar archives (for example .tar, .tar.gz, .bz2, or .tlz) which come from a potentially untrusted source. This advisory is not covered by Drupal Steward. (CVE-2021-32610)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Drupal version 7.82 / 8.9.17 / 9.1.11 / 9.2.2 or later.

See Also







Plugin Details

Severity: High

ID: 151932

File Name: drupal_9_2_2.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 7/22/2021

Updated: 8/19/2021

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-32610


Risk Factor: Medium

Score: 5.2


Risk Factor: Low

Base Score: 3.6

Temporal Score: 2.7

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/21/2021

Vulnerability Publication Date: 7/21/2021

Reference Information

CVE: CVE-2021-32610

IAVA: 2021-A-0353-S