Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : Ruby vulnerabilities (USN-5020-1)

high Nessus Plugin ID 151924
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 / 21.04 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5020-1 advisory.

- An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port.
This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions). (CVE-2021-31810)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5020-1

Plugin Details

Severity: High

ID: 151924

File Name: ubuntu_USN-5020-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 7/22/2021

Updated: 8/30/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-32066

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.4

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, cpe:/o:canonical:ubuntu_linux:21.04, p-cpe:/a:canonical:ubuntu_linux:libruby2.3, p-cpe:/a:canonical:ubuntu_linux:libruby2.5, p-cpe:/a:canonical:ubuntu_linux:libruby2.7, p-cpe:/a:canonical:ubuntu_linux:ruby2.3, p-cpe:/a:canonical:ubuntu_linux:ruby2.3-dev, p-cpe:/a:canonical:ubuntu_linux:ruby2.3-tcltk, p-cpe:/a:canonical:ubuntu_linux:ruby2.5, p-cpe:/a:canonical:ubuntu_linux:ruby2.5-dev, p-cpe:/a:canonical:ubuntu_linux:ruby2.7, p-cpe:/a:canonical:ubuntu_linux:ruby2.7-dev

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 7/21/2021

Vulnerability Publication Date: 5/20/2021

Reference Information

CVE: CVE-2021-31799, CVE-2021-31810, CVE-2021-32066

USN: 5020-1