Amazon Linux AMI : postgresql96 (ALAS-2021-1520)

high Nessus Plugin ID 151507
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

The version of postgresql96 installed on the remote host is prior to 9.6.22-1.85. It is, therefore, affected by a vulnerability as referenced in the ALAS-2021-1520 advisory.

- A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-32027)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update postgresql96' to update your system.

See Also

https://access.redhat.com/security/cve/CVE-2021-32027

https://alas.aws.amazon.com/ALAS-2021-1520.html

Plugin Details

Severity: High

ID: 151507

File Name: ala_ALAS-2021-1520.nasl

Version: 1.3

Type: local

Agent: unix

Published: 7/13/2021

Updated: 8/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-32027

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:amazon:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-contrib:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-docs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-plperl:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-plpython26:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-plpython27:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-server:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-static:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:postgresql96-test:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/8/2021

Vulnerability Publication Date: 5/13/2021

Reference Information

CVE: CVE-2021-32027

ALAS: 2021-1520

IAVB: 2021-B-0036-S