Apache Tomcat 10.0.0.M1 < 10.0.7 vulnerability

medium Nessus Plugin ID 151501

Synopsis

The remote Apache Tomcat server is affected by a vulnerability

Description

The version of Tomcat installed on the remote host is prior to 10.0.7. It is, therefore, affected by a vulnerability as referenced in the fixed_in_apache_tomcat_10.0.7_security-10 advisory. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 10.0.7 or later.

See Also

http://www.nessus.org/u?7fe406bc

http://www.nessus.org/u?fcb8ab85

http://www.nessus.org/u?111c5f0d

http://www.nessus.org/u?fb30afe9

Plugin Details

Severity: Medium

ID: 151501

File Name: tomcat_10_0_7.nasl

Version: 1.6

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 7/12/2021

Updated: 4/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-33037

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/15/2021

Reference Information

CVE: CVE-2021-33037

IAVA: 2021-A-0303-S