Debian DLA-2699-1 : ipmitool - LTS security update

high Nessus Plugin ID 151265

Language:

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has a package installed that is affected by a vulnerability as referenced in the dla-2699 advisory.

- It's been found that multiple functions in ipmitool before 1.8.19 neglect proper checking of the data received from a remote LAN party, which may lead to buffer overflows and potentially to remote code execution on the ipmitool side. This is especially dangerous if ipmitool is run as a privileged user. This problem is fixed in version 1.8.19. (CVE-2020-5208)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ipmitool packages.

For Debian 9 stretch, this problem has been fixed in version 1.8.18-3+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/ipmitool

https://www.debian.org/lts/security/2021/dla-2699

https://security-tracker.debian.org/tracker/CVE-2020-5208

https://packages.debian.org/source/stretch/ipmitool

Plugin Details

Severity: High

ID: 151265

File Name: debian_DLA-2699.nasl

Version: 1.3

Type: local

Agent: unix

Published: 7/1/2021

Updated: 1/21/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2020-5208

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ipmitool, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/30/2021

Vulnerability Publication Date: 2/5/2020

Reference Information

CVE: CVE-2020-5208