RHEL 8 : Red Hat Virtualization Host security update [ovirt-4.4.6] (Important) (RHSA-2021:2522)

high Nessus Plugin ID 150950
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2021:2522 advisory.

- hw: vt-d related privilege escalation (CVE-2020-24489)

- glib: integer overflow in g_bytes_new function on 64-bit platforms due to an implicit cast from 64 bits to 32 bits (CVE-2021-27219)

- kernel: userspace applications can misuse the KVM API to cause a write of 16 bytes at an offset up to 32 GB from vcpu->run (CVE-2021-3501)

- polkit: local privilege escalation using polkit_system_bus_name_get_creds_sync() (CVE-2021-3560)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected redhat-release-virtualization-host, redhat-virtualization-host-image-update and / or redhat- virtualization-host-image-update-placeholder packages.

See Also

https://cwe.mitre.org/data/definitions/190.html

https://cwe.mitre.org/data/definitions/459.html

https://cwe.mitre.org/data/definitions/787.html

https://cwe.mitre.org/data/definitions/863.html

https://access.redhat.com/security/cve/CVE-2020-24489

https://access.redhat.com/security/cve/CVE-2021-3501

https://access.redhat.com/security/cve/CVE-2021-3560

https://access.redhat.com/security/cve/CVE-2021-27219

https://access.redhat.com/errata/RHSA-2021:2522

https://bugzilla.redhat.com/1929858

https://bugzilla.redhat.com/1950136

https://bugzilla.redhat.com/1961710

https://bugzilla.redhat.com/1962650

Plugin Details

Severity: High

ID: 150950

File Name: redhat-RHSA-2021-2522.nasl

Version: 1.7

Type: local

Agent: unix

Published: 6/22/2021

Updated: 10/7/2021

Dependencies: ssh_get_info.nasl, redhat_repos.nasl

Risk Information

CVSS Score Source: CVE-2020-24489

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.8

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:redhat-release-virtualization-host, p-cpe:/a:redhat:enterprise_linux:redhat-virtualization-host-image-update, p-cpe:/a:redhat:enterprise_linux:redhat-virtualization-host-image-update-placeholder

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/22/2021

Vulnerability Publication Date: 2/15/2021

Exploitable With

Metasploit (Polkit D-Bus Authentication Bypass)

Reference Information

CVE: CVE-2020-24489, CVE-2021-3501, CVE-2021-3560, CVE-2021-27219

RHSA: 2021:2522

CWE: 190, 459, 787, 863