Microsoft Windows VP9 Video Extensions Library RCE (June 2021)

high Nessus Plugin ID 150355
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The Windows app installed on the remote host is affected by a remote code execution vulnerability.

Description

The Windows 'VP9 Extensions' app installed on the remote host is affected by a remote code execution vulnerability. An attacker who successfully exploited the vulnerability could execute arbitrary code. Exploitation of the vulnerability requires that a program process a specially crafted file.

Solution

Upgrade to app version 1.0.41182.0, or later via the Microsoft Store.

See Also

http://www.nessus.org/u?af8af611

Plugin Details

Severity: High

ID: 150355

File Name: smb_nt_ms21_june_vp9.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 6/8/2021

Updated: 6/14/2021

Dependencies: smb_hotfixes.nasl, wmi_enum_windows_app_store.nbin

Risk Information

CVSS Score Source: CVE-2021-31967

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/Registry/Enumerated, WMI/Windows App Store/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 6/8/2021

Vulnerability Publication Date: 6/8/2021

Reference Information

CVE: CVE-2021-31967