Debian DSA-180-1 : nis - information leak

medium Nessus Plugin ID 15017
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Thorsten Kukuck discovered a problem in the ypserv program which is part of the Network Information Services (NIS). A memory leak in all versions of ypserv prior to 2.5 is remotely exploitable. When a malicious user could request a non-existing map the server will leak parts of an old domainname and mapname.

Solution

Upgrade the nis package.

This problem has been fixed in version 3.9-6.1 for the current stable distribution (woody), in version 3.8-2.1 for the old stable distribution (potato) and in version 3.9-6.2 for the unstable distribution (sid).

See Also

http://www.debian.org/security/2002/dsa-180

Plugin Details

Severity: Medium

ID: 15017

File Name: debian_DSA-180.nasl

Version: 1.16

Type: local

Agent: unix

Published: 9/29/2004

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nis, cpe:/o:debian:debian_linux:2.2, cpe:/o:debian:debian_linux:3.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 10/21/2002

Reference Information

CVE: CVE-2002-1232

DSA: 180