nginx 0.6.x < 1.20.1 1-Byte Memory Overwrite RCE

critical Nessus Plugin ID 150154

Synopsis

The remote web server is affected by a remote code execution vulnerability.

Description

According to its Server response header, the installed version of nginx is 0.6.18 prior to 1.20.1. It is, therefore, affected by a remote code execution vulnerability. A security issue in nginx resolver was identified, which might allow an unauthenticated remote attacker to cause 1-byte memory overwrite by using a specially crafted DNS response, resulting in worker process crash or, potentially, in arbitrary code execution.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to nginx 1.20.1 or later.

See Also

http://mailman.nginx.org/pipermail/nginx-announce/2021/000300.html

http://nginx.org/download/patch.2021.resolver.txt

Plugin Details

Severity: Critical

ID: 150154

File Name: nginx-2021-000300.nasl

Version: 1.8

Type: combined

Agent: unix

Family: Web Servers

Published: 6/3/2021

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2021-23017

CVSS v3

Risk Factor: Critical

Base Score: 9.4

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nginx:nginx

Required KB Items: installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/25/2021

Vulnerability Publication Date: 5/25/2021

Reference Information

CVE: CVE-2021-23017

IAVB: 2021-B-0031

CWE: 193