Tenable Log Correlation Engine (LCE) < 6.0.9 (TNS-2021-10)

medium Nessus Plugin ID 150139


A data aggregation application installed on the remote host is affected by multiple vulnerabilities.


The version of Tenable Log Correlation Engine (LCE) installed on the remote host is prior to 6.0.9. It is, therefore, affected by multiple vulnerabilities:

- Multiple denial of service vulnerabilities in the included OpenSSL component. (CVE-2019-1551, CVE-2020-1967, CVE-2020-1971, CVE-2021-3449, CVE-2021-23840)

- Multiple cross site scripting vulnerabilities in the included JQuery component. (CVE-2020-11022, CVE-2020-11023)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Tenable LCE version 6.0.9 or later.

See Also


Plugin Details

Severity: Medium

ID: 150139

File Name: lce_6_0_9.nasl

Version: 1.6

Type: local

Agent: unix

Family: Misc.

Published: 6/2/2021

Updated: 12/28/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.7


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2019-1551


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

CVSS Score Source: CVE-2020-11023

Vulnerability Information

CPE: cpe:/a:tenable:log_correlation_engine

Required KB Items: installed_sw/Log Correlation Engine Server

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2021

Vulnerability Publication Date: 12/6/2019

Reference Information

CVE: CVE-2019-1551, CVE-2020-11022, CVE-2020-11023, CVE-2020-1967, CVE-2020-1971, CVE-2021-23840, CVE-2021-3449