Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 : PostgreSQL vulnerabilities (USN-4972-1)

high Nessus Plugin ID 150129

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 20.10 / 21.04 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4972-1 advisory.

- A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-32027)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4972-1

Plugin Details

Severity: High

ID: 150129

File Name: ubuntu_USN-4972-1.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/1/2021

Updated: 8/19/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-32027

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, cpe:/o:canonical:ubuntu_linux:21.04, p-cpe:/a:canonical:ubuntu_linux:libecpg-compat3, p-cpe:/a:canonical:ubuntu_linux:libecpg-dev, p-cpe:/a:canonical:ubuntu_linux:libecpg6, p-cpe:/a:canonical:ubuntu_linux:libpgtypes3, p-cpe:/a:canonical:ubuntu_linux:libpq-dev, p-cpe:/a:canonical:ubuntu_linux:libpq5, p-cpe:/a:canonical:ubuntu_linux:postgresql-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-13, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-13, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-13, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-13, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-13, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-13

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 6/1/2021

Vulnerability Publication Date: 5/13/2021

Reference Information

CVE: CVE-2021-32027, CVE-2021-32028, CVE-2021-32029

USN: 4972-1

IAVB: 2021-B-0036-S