IBM MQ 9.1 LTS / 9.2 < LTS / 9.2 < 9.2.1 CD RCE (6382922)

high Nessus Plugin ID 149782
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is affected by a remote arbitrary code execution vulnerability.


The version of IBM MQ Server running on the remote host is affected by a remote arbitrary code execution vulnerability.
IBM MQ 9.1 LTS, 9.2 LTS, and 9.2 CD could allow a remote attacker to execute arbitrary code on the system, caused by an integer overflow and out-of-bounds write in json-c via a large JSON file. An attacker could exploit this vulnerability to execute arbitrary code on the system.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to IBM MQ LTS, 9.2.1 CD or later. Alternatively, install APAR IT33880 where appropriate.

See Also

Plugin Details

Severity: High

ID: 149782

File Name: ibm_mq_6382922.nasl

Version: 1.2

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 5/19/2021

Updated: 5/21/2021

Dependencies: ibm_mq_nix_installed.nbin, websphere_mq_installed.nasl

Risk Information

CVSS Score Source: CVE-2020-12762


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_mq

Required KB Items: installed_sw/IBM WebSphere MQ

Exploit Ease: No known exploits are available

Patch Publication Date: 12/16/2020

Vulnerability Publication Date: 5/9/2020

Reference Information

CVE: CVE-2020-12762