Samba 3.6.x < 4.12.15 / 4.13.x < 4.13.8 / 4.14.x < 4.14.4 Unauthorized File Access

medium Nessus Plugin ID 149350

Synopsis

The remote Samba server is potentially affected by an unauthorized file access vulnerability.

Description

The version of Samba running on the remote host is 3.6.x prior to 4.12.5, 4.13.x prior to 4.13.8, or 4.14.x prior to 4.14.4. It is, therefore, potentially affected by an unauthorized file access flaw that could allow it to read data beyond the end of the array in the case where a negative cache entry had been added to the mapping cache. This could cause the calling code to return those values into the process token that stores the group membership for a user. The flaw can impact data confidentiality and integrity by allowing unauthorized access.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 4.12.5 / 4.13.8 / 4.14.4 or later.

See Also

https://www.samba.org/samba/security/CVE-2021-20254.html

https://www.samba.org/samba/history/security.html

Plugin Details

Severity: Medium

ID: 149350

File Name: samba_4_14_4.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 5/7/2021

Updated: 1/26/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-20254

CVSS v3

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/29/2021

Vulnerability Publication Date: 4/29/2021

Reference Information

CVE: CVE-2021-20254

IAVA: 2021-A-0208-S