PHP 7.4.x < 7.4.18 / 8.x < 8.0.5 Integer Overflow

high Nessus Plugin ID 149348
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by an integer overflow condition.

Description

The version of PHP installed on the remote host is 7.4.x prior to 7.4.18, or 8.x prior to 8.0.5. It is, therefore, affected by an integer overflow condition in pnctl_exec(). An attacker can exploit this to cause a denial of service (DoS) condition or the execution of arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version

Solution

Upgrade to PHP version 7.4.18, 8.0.5 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.4.18

https://www.php.net/ChangeLog-8.php#8.0.5

Plugin Details

Severity: High

ID: 149348

File Name: php_8_0_5.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 5/7/2021

Updated: 6/3/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of vendor advisory.

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Patch Publication Date: 4/29/2021

Vulnerability Publication Date: 4/29/2021

Reference Information

IAVA: 2021-A-0210-S