GLSA-202104-03 : WebkitGTK+: Multiple vulnerabilities

critical Nessus Plugin ID 149222

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202104-03 (WebkitGTK+: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in WebkitGTK+. Please review the CVE identifiers referenced below for details.
Impact :

An attacker, by enticing a user to visit maliciously crafted web content, may be able to execute arbitrary code, violate iframe sandboxing policy, access restricted ports on arbitrary servers, cause memory corruption, or could cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All WebkitGTK+ users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/webkit-gtk-2.30.6'

See Also

https://webkitgtk.org/security/WSA-2021-0001.html

https://webkitgtk.org/security/WSA-2021-0002.html

https://security.gentoo.org/glsa/202104-03

Plugin Details

Severity: Critical

ID: 149222

File Name: gentoo_GLSA-202104-03.nasl

Version: 1.7

Type: local

Published: 5/3/2021

Updated: 5/6/2022

Risk Information

CVSS Score Source: CVE-2021-1870

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:webkit-gtk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/30/2021

Vulnerability Publication Date: 12/8/2020

CISA Known Exploited Dates: 11/17/2021, 5/25/2022

Reference Information

CVE: CVE-2020-13558, CVE-2020-27918, CVE-2020-29623, CVE-2020-9947, CVE-2021-1765, CVE-2021-1789, CVE-2021-1799, CVE-2021-1801, CVE-2021-1870

GLSA: 202104-03