Pulse Connect Secure < 9.1R11.4 (SA44784)

critical Nessus Plugin ID 148847

Synopsis

The remote device is affected by multiple vulnerabilities.

Description

According to its self-reported version, the version of Pulse Connect Secure running on the remote host is greater than 9.0R3 and prior to 9.1R11.4. It is, therefore, affected by multiple vulnerabilities including an authentication bypass vulnerability that can allow an unauthenticated user to perform remote arbitrary file execution on the Pulse Connect Secure gateway.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Pulse Connect Secure version 9.1R11.4 or later.

See Also

https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44784

Plugin Details

Severity: Critical

ID: 148847

File Name: pulse_connect_secure-sa44784.nasl

Version: 1.15

Type: remote

Family: Misc.

Published: 4/20/2021

Updated: 5/10/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2021-22894

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

CVSS Score Source: CVE-2021-22893

Vulnerability Information

CPE: cpe:/a:pulsesecure:pulse_connect_secure

Required KB Items: installed_sw/Pulse Connect Secure

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/20/2021

Vulnerability Publication Date: 4/20/2021

CISA Known Exploited Dates: 4/23/2021

Reference Information

CVE: CVE-2021-22893, CVE-2021-22894, CVE-2021-22899, CVE-2021-22900

IAVA: 2021-A-0207-S