Jenkins weekly < 2.280 Privilege Escalation

high Nessus Plugin ID 148401


An application running on a remote web server host is affected by a privilege escalation vulnerability


According to its self-reported version number, the version of Jenkins running on the remote web server is Jenkins weekly prior to 2.280. It is, therefore, affected by a privilege escalation vulnerability due to a failure in saving the SecurityContext if it is changed more than once in a single request. If the application's intent is to only allow the user to run with elevated privileges in a small portion of the application, an authenticated remote attacker can leverage this bug to extend those privileges to the rest of the application.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade Jenkins weekly to version 2.280 or later

See Also

Plugin Details

Severity: High

ID: 148401

File Name: jenkins_2_280.nasl

Version: 1.6

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 4/9/2021

Updated: 12/5/2022

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2021-22112


Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins:jenkins

Required KB Items: installed_sw/Jenkins

Exploit Ease: No known exploits are available

Patch Publication Date: 2/19/2021

Vulnerability Publication Date: 2/19/2021

Reference Information

CVE: CVE-2021-22112