Debian DLA-2617-1 : php-nette security update

high Nessus Plugin ID 148311
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote Debian host is missing a security update.

Description

Cyku Hong from DEVCORE discovered that php-nette, a PHP MVC framework, is vulnerable to a code injection attack by passing specially formed parameters to URL that may possibly leading to remote code execution.

For Debian 9 stretch, this problem has been fixed in version 2.4-20160731-1+deb9u1.

We recommend that you upgrade your php-nette packages.

For the detailed security status of php-nette please refer to its security tracker page at:
https://security-tracker.debian.org/tracker/php-nette

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected php-nette package.

See Also

https://lists.debian.org/debian-lts-announce/2021/04/msg00003.html

https://packages.debian.org/source/stretch/php-nette

https://security-tracker.debian.org/tracker/source-package/php-nette

Plugin Details

Severity: High

ID: 148311

File Name: debian_DLA-2617.nasl

Version: 1.3

Type: local

Agent: unix

Published: 4/5/2021

Updated: 4/8/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php-nette, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/4/2021

Vulnerability Publication Date: 10/1/2020

Reference Information

CVE: CVE-2020-15227