ManageEngine OpManager Smart Update Manager RCE

critical Nessus Plugin ID 148307
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A network monitoring application running on the remote host is affected by a remote code execution vulnerability.

Description

The OpManager running on the remote host is affected by an unauthenticated remote code execution vulnerability in the Smart Update Manager (SUM) servlet.

This plugin attempts to detect the issue by sending a serialized Java object to OpManager and looking for a TCP connection initiated from the remote host to the Nessus scanner. In some environments, the TCP SYN packet may not reach the scanner due to network controls. In this case, the plugin may not detect the issue.

Solution

For builds 12.5.204 - 12.5.217, upgrade to OpManager Version 12.5.218 or later. For builds 12.1.000 and above, upgrade to OpManager Version 12.5.203.

See Also

http://www.nessus.org/u?a714af45

Plugin Details

Severity: Critical

ID: 148307

File Name: manageengine_opmanager_cve-2020-28653.nbin

Version: 1.8

Type: remote

Family: CGI abuses

Published: 4/2/2021

Updated: 10/19/2021

Dependencies: manageengine_opmanager_detect.nbin

Risk Information

CVSS Score Source: CVE-2020-28653

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:zohocorp:manageengine_opmanager

Required KB Items: installed_sw/ManageEngine OpManager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/13/2020

Vulnerability Publication Date: 11/7/2020

Exploitable With

Metasploit (ManageEngine OpManager SumPDU Java Deserialization)

Reference Information

CVE: CVE-2020-28653