Apache Druid < 0.20.1 RCE (Direct Check)

high Nessus Plugin ID 148241
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The web application running on the remote web server is affected by a remote code execution vulnerability.


A change introduced in Apache Druid prior to 0.20.1 allows attackers to execute user-provided JavaScript code embedded in various types of requests. This functionality is intended for use in high-trust environments, and is disabled by default. However, in Druid 0.20.0 and earlier, it is possible for an unauthenticated user to send a specially-crafted request that forces Druid to run user-provided JavaScript code for that request, regardless of server configuration. This can be leveraged to execute code on the target machine with the privileges of the Druid server process.


Upgrade to Druid 0.20.1 or later

See Also



Plugin Details

Severity: High

ID: 148241

File Name: apache_druid_cve-2021-25646.nbin

Version: 1.8

Type: remote

Family: Web Servers

Published: 3/30/2021

Updated: 11/29/2021

Dependencies: apache_druid_detect.nbin

Risk Information

CVSS Score Source: CVE-2021-25646


Risk Factor: High

Score: 8.4


Risk Factor: High

Base Score: 9

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C


Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:druid

Required KB Items: installed_sw/Apache Druid

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/29/2021

Vulnerability Publication Date: 1/29/2021

Exploitable With

Metasploit (Apache Druid 0.20.0 Remote Command Execution)

Reference Information

CVE: CVE-2021-25646

CWE: 732