MDaemon < 6.5.2 Multiple Remote Buffer Overflows

High Nessus Plugin ID 14804


The remote SMTP server has multiple buffer overflow vulnerabilities.


According to its banner, the version of MDaemon running on the remote host has multiple buffer overflow vulnerabilities. A remote attacker could exploit these issues to execute arbitrary code.


Upgrade to MDaemon 6.5.2 or later.

See Also

Plugin Details

Severity: High

ID: 14804

File Name: mdaemon_buffer_overflows.nasl

Version: $Revision: 1.16 $

Type: remote

Published: 2004/09/23

Modified: 2016/10/27

Dependencies: 66633

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:alt-n:mdaemon

Required KB Items: mdaemon/installed

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/09/22

Reference Information

CVE: CVE-2004-1546

BID: 11238

OSVDB: 10223, 10224