Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : GLib vulnerabilities (USN-4759-1)

high Nessus Plugin ID 147993
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4759-1 advisory.

- An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation. (CVE-2021-27218)

- An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption. (CVE-2021-27219)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4759-1

Plugin Details

Severity: High

ID: 147993

File Name: ubuntu_USN-4759-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 3/23/2021

Updated: 3/24/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-27219

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, p-cpe:/a:canonical:ubuntu_linux:libgio-fam, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-0, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-0-refdbg, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-bin, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-data, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-dev, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-dev-bin, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-tests, p-cpe:/a:canonical:ubuntu_linux:libglib2.0-udeb

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 3/8/2021

Vulnerability Publication Date: 2/15/2021

Reference Information

CVE: CVE-2021-27218, CVE-2021-27219

USN: 4759-1