Tenable SecurityCenter 5.9.x to 5.12.x SimpleSAMLPHP Privilege Escalation (TNS-2020-01)

high Nessus Plugin ID 147896
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

An application installed on the remote host is affected by a privilege escalation vulnerability.

Description

According to its self-reported version, the Tenable SecurityCenter application installed on the remote host is 5.9.x, 5.10.x, 5.11.x or 5.12.x. It is, therefore, affected by a privilege escalation vulnerability due to incorrect validation of cryptographic signatures in XML messages in the SimpleSAMLPHP third-party component. An authenticated attacker can exploit this to impersonate others or elevate privileges by creating a crafted XML message.

Note that Nessus has not tested for these issues nor the stand-alone patch but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tenable SecurityCenter version 5.13.0 or later or apply a stand-alone patch to address these issues provided by Tenable.

See Also

https://www.tenable.com/security/tns-2020-01-0

Plugin Details

Severity: High

ID: 147896

File Name: securitycenter_5_13_0_tns_2020_01.nasl

Version: 1.3

Type: combined

Agent: unix

Family: Misc.

Published: 3/19/2021

Updated: 3/22/2021

Dependencies: securitycenter_installed.nbin, securitycenter_detect.nbin

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-3465

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Required KB Items: Settings/ParanoidReport, Host/SecurityCenter/Version, installed_sw/SecurityCenter

Exploit Ease: No known exploits are available

Patch Publication Date: 1/7/2020

Vulnerability Publication Date: 1/7/2020

Reference Information

CVE: CVE-2019-3465