Debian DSA-4867-1 : grub2 - security update

high Nessus Plugin ID 146986
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the GRUB2 bootloader.

- CVE-2020-14372 It was discovered that the acpi command allows a privileged user to load crafted ACPI tables when Secure Boot is enabled.

- CVE-2020-25632 A use-after-free vulnerability was found in the rmmod command.

- CVE-2020-25647 An out-of-bound write vulnerability was found in the grub_usb_device_initialize() function, which is called to handle USB device initialization.

- CVE-2020-27749 A stack-based buffer overflow flaw was found in grub_parser_split_cmdline.

- CVE-2020-27779 It was discovered that the cutmem command allows a privileged user to remove memory regions when Secure Boot is enabled.

- CVE-2021-20225 A heap out-of-bounds write vulnerability was found in the short form option parser.

- CVE-2021-20233 A heap out-of-bound write flaw was found caused by mis-calculation of space required for quoting in the menu rendering.

Further detailed information can be found at https://www.debian.org/security/2021-GRUB-UEFI-SecureBoot

Solution

Upgrade the grub2 packages.

For the stable distribution (buster), these problems have been fixed in version 2.02+dfsg1-20+deb10u4.

See Also

https://security-tracker.debian.org/tracker/CVE-2020-14372

https://security-tracker.debian.org/tracker/CVE-2020-25632

https://security-tracker.debian.org/tracker/CVE-2020-25647

https://security-tracker.debian.org/tracker/CVE-2020-27749

https://security-tracker.debian.org/tracker/CVE-2020-27779

https://security-tracker.debian.org/tracker/CVE-2021-20225

https://security-tracker.debian.org/tracker/CVE-2021-20233

https://www.debian.org/security/2021-GRUB-UEFI-SecureBoot

https://security-tracker.debian.org/tracker/source-package/grub2

https://packages.debian.org/source/buster/grub2

https://www.debian.org/security/2021/dsa-4867

Plugin Details

Severity: High

ID: 146986

File Name: debian_DSA-4867.nasl

Version: 1.3

Type: local

Agent: unix

Published: 3/3/2021

Updated: 3/12/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-20233

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:grub2, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 3/2/2021

Vulnerability Publication Date: 3/3/2021

Reference Information

CVE: CVE-2020-14372, CVE-2020-25632, CVE-2020-25647, CVE-2020-27749, CVE-2020-27779, CVE-2021-20225, CVE-2021-20233

DSA: 4867