Mandrake Linux Security Advisory : zlib (MDKSA-2004:090)

Low Nessus Plugin ID 14679


The remote Mandrake Linux host is missing one or more security updates.


Due to a Debian bug report, a Denial of Service vulnerability was discovered in the zlib compression library versions 1.2.x, in the inflate() and inflateBack() functions. Older versions of zlib are not affected.

Once the updated packages have been installed, all programs linked against zlib must be restarted for the new packages to take effect.


Update the affected zlib1 and / or zlib1-devel packages.

Plugin Details

Severity: Low

ID: 14679

File Name: mandrake_MDKSA-2004-090.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/09/08

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:zlib1, p-cpe:/a:mandriva:linux:zlib1-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/09/07

Reference Information

CVE: CVE-2004-0797

MDKSA: 2004:090