Debian DLA-2571-1 : openvswitch security update

high Nessus Plugin ID 146677
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote Debian host is missing a security update.

Description

Several issues have been found in openvswitch, a production quality, multilayer, software-based, Ethernet virtual switch.

CVE-2020-35498

Denial of service attacks, in which crafted network packets could cause the packet lookup to ignore network header fields from layers 3 and 4. The crafted network packet is an ordinary IPv4 or IPv6 packet with Ethernet padding length above 255 bytes. This causes the packet sanity check to abort parsing header fields after layer 2.

CVE-2020-27827

Denial of service attacks using crafted LLDP packets.

CVE-2018-17206

Buffer over-read issue during BUNDLE action decoding.

CVE-2018-17204

Assertion failure due to not validating information (group type and command) in OF1.5 decoder.

CVE-2017-9214

Buffer over-read that is caused by an unsigned integer underflow.

CVE-2015-8011

Buffer overflow in the lldp_decode function in daemon/protocols/lldp.c in lldpd before 0.8.0 allows remote attackers to cause a denial of service (daemon crash) and possibly execute arbitrary code via vectors involving large management addresses and TLV boundaries.

For Debian 9 stretch, these problems have been fixed in version 2.6.10-0+deb9u1. This version is a new upstream point release.

We recommend that you upgrade your openvswitch packages.

For the detailed security status of openvswitch please refer to its security tracker page at:
https://security-tracker.debian.org/tracker/openvswitch

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2021/02/msg00032.html

https://packages.debian.org/source/stretch/openvswitch

https://security-tracker.debian.org/tracker/source-package/openvswitch

Plugin Details

Severity: High

ID: 146677

File Name: debian_DLA-2571.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2/22/2021

Updated: 2/24/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2017-9214

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openvswitch-common, p-cpe:/a:debian:debian_linux:openvswitch-dbg, p-cpe:/a:debian:debian_linux:openvswitch-dev, p-cpe:/a:debian:debian_linux:openvswitch-ipsec, p-cpe:/a:debian:debian_linux:openvswitch-pki, p-cpe:/a:debian:debian_linux:openvswitch-switch, p-cpe:/a:debian:debian_linux:openvswitch-test, p-cpe:/a:debian:debian_linux:openvswitch-testcontroller, p-cpe:/a:debian:debian_linux:openvswitch-vtep, p-cpe:/a:debian:debian_linux:ovn-central, p-cpe:/a:debian:debian_linux:ovn-common, p-cpe:/a:debian:debian_linux:ovn-controller-vtep, p-cpe:/a:debian:debian_linux:ovn-docker, p-cpe:/a:debian:debian_linux:ovn-host, p-cpe:/a:debian:debian_linux:python-openvswitch, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/19/2021

Vulnerability Publication Date: 5/23/2017

Reference Information

CVE: CVE-2015-8011, CVE-2017-9214, CVE-2018-17204, CVE-2018-17206, CVE-2020-27827, CVE-2020-35498