GLSA-200409-06 : eGroupWare: Multiple XSS vulnerabilities

medium Nessus Plugin ID 14653

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200409-06 (eGroupWare: Multiple XSS vulnerabilities)

Joxean Koret recently discovered multiple cross site scripting vulnerabilities in various modules for the eGroupWare suite. This includes the calendar, address book, messenger and ticket modules.
Impact :

These vulnerabilities give an attacker the ability to inject and execute malicious script code, potentially compromising the victim's browser.
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of eGroupWare.

Solution

All eGroupWare users should upgrade to the latest version:
# emerge sync # emerge -pv '>=www-apps/egroupware-1.0.00.004' # emerge '>=www-apps/egroupware-1.0.00.004'

See Also

https://sourceforge.net/forum/forum.php?forum_id=401807

https://www.securityfocus.com/archive/1/372603/2004-08-21/2004-08-27/0

https://security.gentoo.org/glsa/200409-06

Plugin Details

Severity: Medium

ID: 14653

File Name: gentoo_GLSA-200409-06.nasl

Version: 1.17

Type: local

Published: 9/3/2004

Updated: 1/6/2021

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:egroupware, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 9/2/2004

Reference Information

CVE: CVE-2004-1467

GLSA: 200409-06