F5 Networks BIG-IP : BIG-IP APM CTU vulnerability (K29282483)

high Nessus Plugin ID 146403

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

The version of F5 Networks BIG-IP installed on the remote host is prior to 13.1.3.6 / 14.1.4 / 15.1.3.1 / 16.0.1.1 / 16.1.0. It is, therefore, affected by a vulnerability as referenced in the K29282483 advisory.

- In Edge Client version 7.2.x before 7.2.1.1, 7.1.9.x before 7.1.9.8, and 7.1.x-7.1.8.x before 7.1.8.5, an untrusted search path vulnerability in the BIG-IP APM Client Troubleshooting Utility (CTU) for Windows could allow an attacker to load a malicious DLL library from its current directory. User interaction is required to exploit this vulnerability in that the victim must run this utility on the Windows system.
Note: Software versions which have reached End of Software Development (EoSD) are not evaluated.
(CVE-2021-22980)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution K29282483.

See Also

https://support.f5.com/csp/article/K29282483

Plugin Details

Severity: High

ID: 146403

File Name: f5_bigip_SOL29282483.nasl

Version: 1.8

Type: local

Published: 2/11/2021

Updated: 10/28/2021

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-22980

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:f5:big-ip_access_policy_manager, cpe:/h:f5:big-ip

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/10/2021

Vulnerability Publication Date: 2/12/2021

Reference Information

CVE: CVE-2021-22980