Ubuntu 18.04 LTS : Linux kernel vulnerability (USN-4713-2)

high Nessus Plugin ID 146349

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 18.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-4713-2 advisory.

- In drivers/target/target_core_xcopy.c in the Linux kernel before 5.10.7, insufficient identifier checking in the LIO SCSI target code can be used by remote attackers to read or write files via directory traversal in an XCOPY request, aka CID-2896c93811e3. For example, an attack can occur over a network if the attacker has access to one iSCSI LUN. The attacker gains control over file access because I/O operations are proxied via an attacker-selected backstore. (CVE-2020-28374)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4713-2

Plugin Details

Severity: High

ID: 146349

File Name: ubuntu_USN-4713-2.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2/10/2021

Updated: 1/17/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-28374

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-184-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-184-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-184-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.0.0-1051-gke, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.3.0-1037-raspi2, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.3.0-1040-gke, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.3.0-70-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.3.0-70-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-lts-saucy, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-lts-trusty, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lts-quantal, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lts-raring, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lts-saucy, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lts-trusty, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-pae, p-cpe:/a:canonical:ubuntu_linux:linux-image-gke-5.0, p-cpe:/a:canonical:ubuntu_linux:linux-image-gke-5.3, p-cpe:/a:canonical:ubuntu_linux:linux-image-gkeop-5.3, p-cpe:/a:canonical:ubuntu_linux:linux-image-highbank, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-pae, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi2-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-server, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/10/2021

Vulnerability Publication Date: 1/13/2021

Reference Information

CVE: CVE-2020-28374

USN: 4713-2