PHP 7.3.x < 7.3.27 / 7.4.x < 7.4.15 / 8.x < 8.0.2 DoS

high Nessus Plugin ID 146311
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The version of PHP running on the remote web server is affected by a denial of service vulnerability.


The version of PHP installed on the remote host is 7.3.x prior to 7.3.27, 7.4.x prior to 7.4.15, or 8.x prior to 8.0.2.
It is, therefore, affected by a denial of service (DoS) vulnerability due to a null dereference in SoapClient. An unauthenticated, remote attacker can exploit this, by providing an XML to the SoapCLient query() function without an existing field, in order to cause PHP to crash.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version


Upgrade to PHP version 7.3.27, 7.4.15, 8.0.2 or later.

See Also

Plugin Details

Severity: High

ID: 146311

File Name: php_8_0_2.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2/9/2021

Updated: 6/3/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2021-21702


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2/4/2021

Vulnerability Publication Date: 2/4/2021

Reference Information

CVE: CVE-2021-21702

IAVA: 2021-A-0082-S