GLSA-200408-20 : Qt: Image loader overflows

High Nessus Plugin ID 14576


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200408-20 (Qt: Image loader overflows)

There are several unspecified bugs in the QImage class which may cause crashes or allow execution of arbitrary code as the user running the Qt application. These bugs affect the PNG, XPM, BMP, GIF and JPEG image types.
Impact :

An attacker may exploit these bugs by causing a user to open a carefully-constructed image file in any one of these formats. This may be accomplished through e-mail attachments (if the user uses KMail), or by simply placing a malformed image on a website and then convicing the user to load the site in a Qt-based browser (such as Konqueror).
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Qt.


All Qt users should upgrade to the latest version:
# emerge sync # emerge -pv '>=x11-libs/qt-3.3.3' # emerge '>=x11-libs/qt-3.3.3'

See Also

Plugin Details

Severity: High

ID: 14576

File Name: gentoo_GLSA-200408-20.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/08/30

Modified: 2016/05/20

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:qt, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/08/22

Vulnerability Publication Date: 2004/08/18

Reference Information

CVE: CVE-2004-0691, CVE-2004-0692, CVE-2004-0693

OSVDB: 9026, 9035, 9036

GLSA: 200408-20