GLSA-200408-18 : xine-lib: VCD MRL buffer overflow

Medium Nessus Plugin ID 14574


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200408-18 (xine-lib: VCD MRL buffer overflow)

xine-lib contains a bug where it is possible to overflow the vcd:// input source identifier management buffer through carefully crafted playlists.
Impact :

An attacker may construct a carefully-crafted playlist file which will cause xine-lib to execute arbitrary code with the permissions of the user. In order to conform with the generic naming standards of most Unix-like systems, playlists can have extensions other than .asx (the standard xine playlist format), and made to look like another file (MP3, AVI, or MPEG for example). If an attacker crafts a playlist with a valid header, they can insert a VCD playlist line that can cause a buffer overflow and possible shellcode execution.
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of xine-lib.


All xine-lib users should upgrade to the latest version:
# emerge sync # emerge -pv '>=media-libs/xine-lib-1_rc5-r3' # emerge '>=media-libs/xine-lib-1_rc5-r3'

See Also

Plugin Details

Severity: Medium

ID: 14574

File Name: gentoo_GLSA-200408-18.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xine-lib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/08/17

Vulnerability Publication Date: 2004/08/08

Reference Information

CVE: CVE-2004-1475

OSVDB: 8409

GLSA: 200408-18