GLSA-200408-10 : gv: Exploitable Buffer Overflow

Medium Nessus Plugin ID 14566


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200408-10 (gv: Exploitable Buffer Overflow)

gv contains a buffer overflow vulnerability where an unsafe sscanf() call is used to interpret PDF and PostScript files.
Impact :

By enticing a user to view a malformed PDF or PostScript file an attacker could execute arbitrary code with the permissions of the user running gv.
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of gv.


All gv users should upgrade to the latest version:
# emerge sync # emerge -pv '>=app-text/gv-3.5.8-r4' # emerge '>=app-text/gv-3.5.8-r4'

See Also

Plugin Details

Severity: Medium

ID: 14566

File Name: gentoo_GLSA-200408-10.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gv, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/08/12

Vulnerability Publication Date: 2002/12/04

Reference Information

CVE: CVE-2002-0838

OSVDB: 8649, 8650, 8651

GLSA: 200408-10