VMware vCenter REST API Data Collection

info Nessus Plugin ID 145402
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Collects all data from VMware vCenter via the REST API.

Description

Collects vSphere host data from the targeted VMware vCenter host via the REST API.

Plugin Details

Severity: Info

ID: 145402

File Name: vmware_vcenter_rest_collect.nbin

Version: 1.18

Type: remote

Published: 1/25/2021

Updated: 10/12/2021

Dependencies: vmware_vcenter_settings.nbin, vmware_vcenter_detect.nbin, vmware_vsphere_detect.nbin

Vulnerability Information

CPE: cpe:/a:vmware:vcenter, cpe:/a:vmware:vcenter_server

Required KB Items: Host/vCenter/host, Host/vCenter/port, Host/vCenter/ssl, Host/vCenter/verify_ssl, Secret/vCenter/username, Secret/vCenter/password