GLSA-200406-19 : giFT-FastTrack: remote denial of service attack

Medium Nessus Plugin ID 14530


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200406-19 (giFT-FastTrack: remote denial of service attack)

Alan Fitton found a vulnerability in the giFT-FastTrack plugin in version 0.8.6 and earlier. It can be used to remotely crash the giFT daemon.
Impact :

Attackers may use this vulnerability to perform a Denial of Service attack against the giFT daemon. There is no risk of code execution.
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.


All users should upgrade to the latest available version of gift-fasttrack:
# emerge sync # emerge -pv '>=net-p2p/gift-fasttrack-0.8.7' # emerge '>=net-p2p/gift-fasttrack-0.8.7'

See Also

Plugin Details

Severity: Medium

ID: 14530

File Name: gentoo_GLSA-200406-19.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gift-fasttrack, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/06/24

Vulnerability Publication Date: 2004/06/24

Reference Information

CVE: CVE-2004-0604

OSVDB: 7266

GLSA: 200406-19