GLSA-200406-10 : Gallery: Privilege escalation vulnerability

Critical Nessus Plugin ID 14521


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200406-10 (Gallery: Privilege escalation vulnerability)

There is a vulnerability in the Gallery photo album software which may allow an attacker to gain administrator privileges within Gallery. A Gallery administrator has full access to all albums and photos on the server, thus attackers may add or delete photos at will.
Impact :

Attackers may gain full access to all Gallery albums. There is no risk to the webserver itself, or the server on which it runs.
Workaround :

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.


All users should upgrade to the latest available version of Gallery.
# emerge sync # emerge -pv '>=www-apps/gallery-1.4.3_p2' # emerge '>=www-apps/gallery-1.4.3_p2'

See Also

Plugin Details

Severity: Critical

ID: 14521

File Name: gentoo_GLSA-200406-10.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/08/30

Modified: 2017/08/14

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:ND/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gallery, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2004/06/15

Vulnerability Publication Date: 2004/06/01

Reference Information

CVE: CVE-2004-0522

OSVDB: 6524

GLSA: 200406-10