GLSA-200406-09 : Horde-Chora: Remote code execution

High Nessus Plugin ID 14520


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200406-09 (Horde-Chora: Remote code execution)

A vulnerability in the diff viewer of Chora allows an attacker to inject shellcode. An attacker can exploit PHP's file upload functionality to upload a malicious binary to a vulnerable server, chmod it as executable, and run the file.
Impact :

An attacker could remotely execute arbitrary binaries with the permissions of the PHP script, conceivably allowing further exploitation of local vulnerabilities and remote root access.
Workaround :

There is no known workaround at this time.


All users are advised to upgrade to the latest version of Chora:
# emerge sync # emerge -pv '>=www-apps/horde-chora-1.2.2' # emerge '>=www-apps/horde-chora-1.2.2'

See Also

Plugin Details

Severity: High

ID: 14520

File Name: gentoo_GLSA-200406-09.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:horde-chora, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/06/15

Vulnerability Publication Date: 2004/06/13

Reference Information

OSVDB: 7005

GLSA: 200406-09