EulerOS 2.0 SP3 : pcp (EulerOS-SA-2021-1106)

high Nessus Plugin ID 145135
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the pcp packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- A Improper Control of Generation of Code vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5 openSUSE Leap 15.1 allows the user pcp to run code as root by placing it into /var/log/pcp/configs.sh This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1.
SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1.
SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.(CVE-2019-3695)

- A Improper Limitation of a Pathname to a Restricted Directory vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5 openSUSE Leap 15.1 allows local user pcp to overwrite arbitrary files with arbitrary content. This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1.
SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1.
SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.(CVE-2019-3696)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected pcp packages.

See Also

http://www.nessus.org/u?c499b5fa

Plugin Details

Severity: High

ID: 145135

File Name: EulerOS_SA-2021-1106.nasl

Version: 1.2

Type: local

Published: 1/20/2021

Updated: 1/22/2021

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:pcp, p-cpe:/a:huawei:euleros:pcp-compat, p-cpe:/a:huawei:euleros:pcp-conf, p-cpe:/a:huawei:euleros:pcp-doc, p-cpe:/a:huawei:euleros:pcp-export-pcp2graphite, p-cpe:/a:huawei:euleros:pcp-gui, p-cpe:/a:huawei:euleros:pcp-libs, p-cpe:/a:huawei:euleros:pcp-pmda-activemq, p-cpe:/a:huawei:euleros:pcp-pmda-apache, p-cpe:/a:huawei:euleros:pcp-pmda-bash, p-cpe:/a:huawei:euleros:pcp-pmda-bonding, p-cpe:/a:huawei:euleros:pcp-pmda-cisco, p-cpe:/a:huawei:euleros:pcp-pmda-dbping, p-cpe:/a:huawei:euleros:pcp-pmda-dm, p-cpe:/a:huawei:euleros:pcp-pmda-ds389, p-cpe:/a:huawei:euleros:pcp-pmda-ds389log, p-cpe:/a:huawei:euleros:pcp-pmda-elasticsearch, p-cpe:/a:huawei:euleros:pcp-pmda-gfs2, p-cpe:/a:huawei:euleros:pcp-pmda-gluster, p-cpe:/a:huawei:euleros:pcp-pmda-gpfs, p-cpe:/a:huawei:euleros:pcp-pmda-gpsd, p-cpe:/a:huawei:euleros:pcp-pmda-json, p-cpe:/a:huawei:euleros:pcp-pmda-kvm, p-cpe:/a:huawei:euleros:pcp-pmda-lmsensors, p-cpe:/a:huawei:euleros:pcp-pmda-logger, p-cpe:/a:huawei:euleros:pcp-pmda-lustre, p-cpe:/a:huawei:euleros:pcp-pmda-lustrecomm, p-cpe:/a:huawei:euleros:pcp-pmda-mailq, p-cpe:/a:huawei:euleros:pcp-pmda-memcache, p-cpe:/a:huawei:euleros:pcp-pmda-mounts, p-cpe:/a:huawei:euleros:pcp-pmda-mysql, p-cpe:/a:huawei:euleros:pcp-pmda-named, p-cpe:/a:huawei:euleros:pcp-pmda-netfilter, p-cpe:/a:huawei:euleros:pcp-pmda-news, p-cpe:/a:huawei:euleros:pcp-pmda-nfsclient, p-cpe:/a:huawei:euleros:pcp-pmda-nginx, p-cpe:/a:huawei:euleros:pcp-pmda-nvidia-gpu, p-cpe:/a:huawei:euleros:pcp-pmda-pdns, p-cpe:/a:huawei:euleros:pcp-pmda-postfix, p-cpe:/a:huawei:euleros:pcp-pmda-postgresql, p-cpe:/a:huawei:euleros:pcp-pmda-roomtemp, p-cpe:/a:huawei:euleros:pcp-pmda-rpm, p-cpe:/a:huawei:euleros:pcp-pmda-sendmail, p-cpe:/a:huawei:euleros:pcp-pmda-shping, p-cpe:/a:huawei:euleros:pcp-pmda-summary, p-cpe:/a:huawei:euleros:pcp-pmda-trace, p-cpe:/a:huawei:euleros:pcp-pmda-unbound, p-cpe:/a:huawei:euleros:pcp-pmda-weblog, p-cpe:/a:huawei:euleros:pcp-pmda-zswap, p-cpe:/a:huawei:euleros:pcp-system-tools, p-cpe:/a:huawei:euleros:perl-PCP-PMDA, p-cpe:/a:huawei:euleros:python-pcp, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Exploit Available: undefined

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2021

Reference Information

CVE: CVE-2019-3695, CVE-2019-3696