GLSA-200405-25 : tla: Multiple vulnerabilities in included libneon

Medium Nessus Plugin ID 14511


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200405-25 (tla: Multiple vulnerabilities in included libneon)

Multiple format string vulnerabilities and a heap overflow vulnerability were discovered in the code of the neon library (GLSA 200405-01 and 200405-13). Current versions of the tla package include their own version of this library.
Impact :

When connected to a malicious WebDAV server, these vulnerabilities could allow execution of arbitrary code with the rights of the user running tla.
Workaround :

There is no known workaround at this time.


All users of tla should upgrade to the latest stable version:
# emerge sync # emerge -pv '>=dev-util/tla-1.2-r2' # emerge '>=dev-util/tla-1.2-r2'

See Also

Plugin Details

Severity: Medium

ID: 14511

File Name: gentoo_GLSA-200405-25.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/08/30

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tla, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/05/30

Vulnerability Publication Date: 2004/04/15

Reference Information

OSVDB: 5365, 6302

GLSA: 200405-25